asterisk-chan-capi_wrong_verison

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

asterisk-chan-capi_wrong_verison [17.06.2010 18:09] (current)
Pascal Suter created
Line 1: Line 1:
 +====== asterisk-chan-capi: wrong version ======
 +
 +===== Problem =====
 +when asterisk is installed via apt-get install asterisk and chan capi is also installed via apt-get the versions don't match and asterisk won't load chan capi 
 +
 +<code>
 +[May 3 15:45:41] WARNING[1245] loader.c: Module 'chan_capi.so' was not compiled with the same compile-time options as this version of Asterisk.
 +[May 3 15:45:41] WARNING[1245] loader.c: Module 'chan_capi.so' will not be initialized as it may cause instability.
 +[May 3 15:45:41] WARNING[1245] loader.c: Module 'chan_capi.so' could not be loaded.
 +</code>
 +
 +===== Solution =====
 +re compile chan capi 
 +
 +<code>
 +apt-get build-dep asterisk-chan-capi
 +apt-get --build source asterisk-chan-capi
 +dpkg -i asterisk-chan-capi_1.1.4-1_i386.deb
 +</code>
 +
 +
  
  • asterisk-chan-capi_wrong_verison.txt
  • Last modified: 17.06.2010 18:09
  • by Pascal Suter